scratchpay.com is currently experiencing an outage

Incident Report for Scratchpay Status

Resolved

Our internal team has confirmed the scratchpay.com service is fully restored.
Posted Feb 16, 2026 - 05:31 PST

Monitoring

scratchpay.com has been restored and we're actively monitoring the service.
Posted Feb 16, 2026 - 04:55 PST

Investigating

We are aware that scratchpay.com is currently unavailable and our team is actively investigating the issue. We do not have an estimated time of resolution at this time, but will provide updates as more information becomes available.
Posted Feb 16, 2026 - 04:36 PST
This incident affected: scratchpay.com.